File libkolabxml.spec of Package libkolabxml (Revision d2d007ed2ef2277c5532bc43187f5959)

Currently displaying revision d2d007ed2ef2277c5532bc43187f5959 , Show latest

834
 
1
# Needed for opensuse build system
2
%if 0%{?opensuse_bs}
3
#!BuildIgnore:  fedora-logos-httpd
4
#!BuildIgnore:  httpd
5
%endif
6
7
# The cmake macro changed to build out of source by default, which breaks our own out of source build, so disable that.
8
%define __cmake_in_source_build 1
9
10
%{?!mono_arches: %global mono_arches %{ix86} x86_64 sparc sparcv9 ia64 %{arm} alpha s390x ppc ppc64}
11
12
%ifarch %{mono_arches}
13
# No linux system is actually using the csharp bindings
14
%global with_csharp 0
15
%endif
16
%global with_java 1
17
%global with_php 1
18
%if 0%{?rhel} >= 9
19
%global with_python 0
20
%else
21
%global with_python 1
22
%endif
23
%global with_python3 1
24
25
26
%if 0%{?with_php} > 0
27
28
%{expand: %(if [ `php-config --vernum` -gt 70000 ]; then echo %%global with_php7 1; else echo %%global with_php7 0; fi)}
29
30
%if 0%{?suse_version}
31
%global php php5
32
%{!?php_extdir: %global php_extdir %{_libdir}/php5/extensions}
33
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php5/conf.d/}
34
%else
35
%global php php
36
%{!?php_extdir: %global php_extdir %{_libdir}/php/modules}
37
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d/}
38
%endif
39
%{!?php_apiver: %global php_apiver  %((echo 0; php -i 2>/dev/null | sed -n 's/^PHP API => //p') | tail -1)}
40
%endif
41
42
%if 0%{?with_python} > 0
43
%{!?python2_sitelib: %global python2_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
44
%{!?python2_sitearch: %global python2_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
45
%endif
46
47
%if 0%{?with_python3} > 0
48
%{!?python3_sitelib: %global python3_sitelib %(%{__python3} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
49
%{!?python3_sitearch: %global python3_sitearch %(%{__python3} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
50
%endif
51
52
%if 0%{?with_python3} > 0
53
%{?filter_setup:
54
%filter_provides_in %{python2_sitearch}/.*\.so$
55
%filter_provides_in %{python3_sitearch}/.*\.so$
56
%filter_provides_in %{php_extdir}/.*\.so$
57
%filter_setup
58
}
59
%else
60
%{?filter_setup:
61
%filter_provides_in %{php_extdir}/.*\.so$
62
%filter_setup
63
}
64
%endif
65
66
%if 0%{?suse_version}
67
Name:           libkolabxml1
68
%else
69
Name:           libkolabxml
70
%endif
71
Version:        1.3.0
72
Release:        1%{?dist}
73
Summary:        Kolab XML format collection parser library
74
75
Group:          System Environment/Libraries
76
License:        LGPLv3+
77
URL:            http://www.kolab.org
78
79
Source0:        libkolabxml-%{version}.tar.gz
80
81
Patch1002:      at11.0-boost-this_thread-hidden-sleep_until.patch
82
83
BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
84
85
BuildRequires:  boost-devel
86
BuildRequires:  cmake >= 2.6
87
%if 0%{?rhel} >= 8 || 0%{?fedora}
88
BuildRequires:  extra-cmake-modules
89
%endif
90
BuildRequires:  e2fsprogs-devel
91
BuildRequires:  gcc-c++
92
BuildRequires:  libcurl-devel
93
BuildRequires:  make
94
95
%if 0%{?suse_version}
96
BuildRequires:  qt-devel
97
%else
98
%if 0%{?rhel} >= 8 || 0%{?fedora}
99
BuildRequires:  qt5-qtbase-devel
100
%else
101
BuildRequires:  qt4-devel
102
%endif
103
%endif
104
BuildRequires:  swig >= 4.1
105
BuildRequires:  uuid-devel
106
BuildRequires:  xsd
107
108
%if 0%{?suse_version}
109
BuildRequires:  libxerces-c-devel
110
%else
111
BuildRequires:  xerces-c-devel
112
%endif
113
114
# For running zonetabconversion.py
115
%if 0%{?rhel} >= 8 || 0%{?fedora}
116
BuildRequires:  python3
117
%else
118
BuildRequires:  python
119
%endif
120
121
Provides:       libkolabxml%{?_isa} = %{version}
122
123
%if 0%{?with_csharp} < 1
124
Obsoletes:      csharp-kolabformat < %{version}-%{release}
125
Provides:       csharp-kolabformat = %{version}-%{release}
126
%endif
127
128
%if 0%{?with_java} < 1
129
Obsoletes:      java-kolabformat < %{version}-%{release}
130
Provides:       java-kolabformat = %{version}-%{release}
131
%endif
132
133
%if 0%{?with_php} < 1
134
Obsoletes:      php-kolabformat < %{version}-%{release}
135
Provides:       php-kolabformat = %{version}-%{release}
136
%endif
137
138
%if 0%{?with_python} < 1
139
Obsoletes:      python-kolabformat < %{version}-%{release}
140
Provides:       python-kolabformat = %{version}-%{release}
141
%endif
142
143
%if 0%{?with_python3} < 1
144
Obsoletes:      python3-kolabformat < %{version}-%{release}
145
Provides:       python3-kolabformat = %{version}-%{release}
146
%endif
147
148
%description
149
The libkolabxml parsing library interprets Kolab XML formats (xCal, xCard)
150
with bindings for Python, PHP and other languages. The language bindings
151
are available through sub-packages.
152
153
%if 0%{?suse_version}
154
%package -n libkolabxml-devel
155
%else
156
%package devel
157
%endif
158
Summary:        Kolab XML library development headers
159
Group:          Development/Libraries
160
Requires:       libkolabxml%{?_isa} = %{version}
161
Requires:       boost-devel
162
Requires:       cmake >= 2.6
163
%if 0%{?rhel} >= 8 || 0%{?fedora}
164
Requires:       extra-cmake-modules
165
%endif
166
Requires:       e2fsprogs-devel
167
Requires:       gcc-c++
168
Requires:       libcurl-devel
169
%if 0%{?with_php} > 0
170
Requires:       php-devel >= 5.3
171
%if 0%{?plesk}
172
%if 0%{?rhel} < 9
173
Requires:       plesk-php72-devel
174
Requires:       plesk-php73-devel
175
%endif
176
Requires:       plesk-php74-devel
177
Requires:       plesk-php80-devel
178
Requires:       plesk-php81-devel
179
%endif
180
%endif
181
%if 0%{?with_python} > 0
182
%if 0%{?rhel} >= 8
183
Requires:       python2-devel
184
%else
185
Requires:       python-devel
186
%endif
187
%endif
188
%if 0%{?with_python3} > 0
189
Requires:       python3-devel
190
%endif
191
%if 0%{?suse_version}
192
Requires:       qt-devel
193
%else
194
%if 0%{?fedora} || 0%{?rhel} >= 8
195
Requires:       qt5-qtbase-devel
196
%else
197
Requires:       qt4-devel
198
%endif
199
%endif
200
Requires:       uuid-devel
201
%if 0%{?suse_version}
202
Requires:       libxerces-c-devel
203
%else
204
Requires:       xerces-c-devel
205
%endif
206
Requires:       xsd
207
208
%if 0%{?suse_version}
209
%description -n libkolabxml-devel
210
%else
211
%description devel
212
%endif
213
Development headers for the Kolab XML libraries.
214
215
%if 0%{?with_csharp} > 0
216
%package -n csharp-kolabformat
217
Summary:        C# Bindings for libkolabxml
218
Group:          System Environment/Libraries
219
Requires:       libkolabxml%{?_isa} = %{version}
220
%if 0%{?suse_version}
221
Obsoletes:      mono-%{name} < %{version}
222
Provides:       mono-%{name} = %{version}
223
%endif
224
BuildRequires:  mono-core
225
226
%description -n csharp-kolabformat
227
C# bindings for libkolabxml
228
%endif
229
230
%if 0%{?with_java} > 0
231
%package -n java-kolabformat
232
Summary:        Java Bindings for libkolabxml
233
Group:          System Environment/Libraries
234
Requires:       libkolabxml%{?_isa} = %{version}
235
%if 0%{?suse_version}
236
Obsoletes:      java-%{name} < %{version}
237
Provides:       java-%{name} = %{version}
238
%endif
239
240
%description -n java-kolabformat
241
Java bindings for libkolabxml
242
%endif
243
244
%if 0%{?with_php} > 0
245
%package -n php-kolabformat
246
Summary:        PHP bindings for libkolabxml
247
Group:          System Environment/Libraries
248
Provides:       php-bindings(libkolabxml) = %{version}-%{release}
249
Requires:       libkolabxml%{?_isa} = %{version}
250
%if 0%{?rhel} > 5 || 0%{?fedora} > 15
251
Requires:       php(zend-abi) = %{php_zend_api}
252
Requires:       php(api) = %{php_core_api}
253
%else
254
Requires:       php-api = %{php_apiver}
255
%endif
256
%if 0%{?suse_version}
257
Obsoletes:      php-%{name} < %{version}
258
Provides:       php-%{name} = %{version}
259
%endif
260
# openSUSE apparently does not have its -devel subpackages require the base
261
# package
262
BuildRequires:  php >= 5.3
263
BuildRequires:  php-devel >= 5.3
264
%if 0%{?plesk}
265
%if 0%{?rhel} < 9
266
BuildRequires:  plesk-php72-devel
267
BuildRequires:  plesk-php73-devel
268
%endif
269
BuildRequires:  plesk-php74-devel
270
BuildRequires:  plesk-php80-devel
271
BuildRequires:  plesk-php81-devel
272
%endif
273
274
%description -n php-kolabformat
275
The PHP kolabformat package offers a comprehensible PHP library using the
276
bindings provided through libkolabxml.
277
%endif
278
279
%if 0%{?plesk}
280
%if 0%{?rhel} < 9
281
%package -n plesk-php72-kolabformat
282
Summary:        libkolabxml bindings for Plesk's PHP 7.2
283
Group:          System Environment/Libraries
284
Provides:       php-bindings(libkolabxml) = %{version}-%{release}
285
Requires:       libkolabxml%{?_isa} = %{version}
286
Requires:       plesk-php72
287
288
%description -n plesk-php72-kolabformat
289
libkolabxml bindings for Plesk's PHP 7.2
290
291
%package -n plesk-php73-kolabformat
292
Summary:        libkolabxml bindings for Plesk's PHP 7.3
293
Group:          System Environment/Libraries
294
Provides:       php-bindings(libkolabxml) = %{version}-%{release}
295
Requires:       libkolabxml%{?_isa} = %{version}
296
Requires:       plesk-php73
297
298
%description -n plesk-php73-kolabformat
299
libkolabxml bindings for Plesk's PHP 7.3
300
301
%endif
302
%package -n plesk-php74-kolabformat
303
Summary:        libkolabxml bindings for Plesk's PHP 7.4
304
Group:          System Environment/Libraries
305
Provides:       php-bindings(libkolabxml) = %{version}-%{release}
306
Requires:       libkolabxml%{?_isa} = %{version}
307
Requires:       plesk-php74
308
309
%description -n plesk-php74-kolabformat
310
libkolabxml bindings for Plesk's PHP 7.4
311
312
%package -n plesk-php80-kolabformat
313
Summary:        libkolabxml bindings for Plesk's PHP 8.0
314
Group:          System Environment/Libraries
315
Provides:       php-bindings(libkolabxml) = %{version}-%{release}
316
Requires:       libkolabxml%{?_isa} = %{version}
317
Requires:       plesk-php80
318
319
%description -n plesk-php80-kolabformat
320
libkolabxml bindings for Plesk's PHP 8.0
321
322
%package -n plesk-php81-kolabformat
323
Summary:        libkolabxml bindings for Plesk's PHP 8.1
324
Group:          System Environment/Libraries
325
Provides:       php-bindings(libkolabxml) = %{version}-%{release}
326
Requires:       libkolabxml%{?_isa} = %{version}
327
Requires:       plesk-php81
328
329
%description -n plesk-php81-kolabformat
330
libkolabxml bindings for Plesk's PHP 8.1
331
332
%endif # if 0%{?plesk}
333
334
%if 0%{?with_python} > 0
335
%package -n python-kolabformat
336
Summary:        Python bindings for libkolabxml
337
Group:          System Environment/Libraries
338
Requires:       libkolabxml%{?_isa} = %{version}
339
%if 0%{?suse_version}
340
Obsoletes:      python-%{name} < %{version}
341
Provides:       python-%{name} = %{version}
342
%endif
343
%if 0%{?rhel} >= 8 || 0%{?fedora}
344
BuildRequires:  python2-devel
345
%else
346
BuildRequires:  python-devel
347
%endif
348
349
%description -n python-kolabformat
350
The PyKolab format package offers a comprehensive Python library using the
351
bindings provided through libkolabxml.
352
%endif
353
354
%if 0%{?with_python3} > 0
355
%package -n python3-kolabformat
356
Summary:        Python3 bindings for libkolabxml
357
Group:          System Environment/Libraries
358
Requires:       libkolabxml%{?_isa} = %{version}
359
%if 0%{?suse_version}
360
Obsoletes:      python3-%{name} < %{version}
361
Provides:       python3-%{name} = %{version}
362
%endif
363
BuildRequires:  python3-devel
364
365
%description -n python3-kolabformat
366
The PyKolab format package offers a comprehensive Python library using the
367
bindings provided through libkolabxml.
368
%endif
369
370
%prep
371
%setup -q -c -n libkolabxml-%{version}
372
pwd
373
ls -l
374
375
%if 0%{?with_at}
376
%patch1002 -p1
377
%endif
378
379
%if 0%{?plesk}
380
%if 0%{?rhel} < 9
381
cp -a libkolabxml-%{version} libkolabxml-%{version}-7.2
382
sed -i "s/-php/-php7/g" libkolabxml-%{version}-7.2/src/php/CMakeLists.txt
383
384
cp -a libkolabxml-%{version} libkolabxml-%{version}-7.3
385
sed -i "s/-php/-php7/g" libkolabxml-%{version}-7.3/src/php/CMakeLists.txt
386
387
%endif
388
cp -a libkolabxml-%{version} libkolabxml-%{version}-7.4
389
sed -i "s/-php/-php7/g" libkolabxml-%{version}-7.4/src/php/CMakeLists.txt
390
391
cp -a libkolabxml-%{version} libkolabxml-%{version}-8.0
392
sed -i "s/-php/-php7/g" libkolabxml-%{version}-8.0/src/php/CMakeLists.txt
393
394
cp -a libkolabxml-%{version} libkolabxml-%{version}-8.1
395
sed -i "s/-php/-php7/g" libkolabxml-%{version}-8.1/src/php/CMakeLists.txt
396
%endif
397
398
%if 0%{?with_php7}
399
pushd %{name}-%{version}
400
sed -i "s/-php/-php7/g" src/php/CMakeLists.txt
401
popd
402
%endif
403
404
%if 0%{?with_python3} > 0
405
cp -a libkolabxml-%{version} libkolabxml-%{version}-python3
406
%endif
407
408
%build
409
pushd %{name}-%{version}
410
%if 0%{?rhel} >= 8 || 0%{?fedora}
411
%{python3} utils/zonetabconversion.py
412
%else
413
%{__python2} utils/zonetabconversion.py
414
%endif
415
popd
416
417
%if 0%{?plesk}
418
%if 0%{?rhel} < 9
419
cp %{name}-%{version}/tztable.h %{name}-%{version}-7.2/.
420
cp %{name}-%{version}/tztable.h %{name}-%{version}-7.3/.
421
%endif
422
cp %{name}-%{version}/tztable.h %{name}-%{version}-7.4/.
423
cp %{name}-%{version}/tztable.h %{name}-%{version}-8.0/.
424
cp %{name}-%{version}/tztable.h %{name}-%{version}-8.1/.
425
%endif
426
%if 0%{?with_python3} > 0
427
cp %{name}-%{version}/tztable.h %{name}-%{version}-python3/.
428
%endif
429
430
pushd %{name}-%{version}
431
rm -rf build
432
mkdir -p build
433
pushd build
434
%if 0%{?suse_version}
435
CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
436
CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
437
FFLAGS="${FFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}" ; export FFLAGS ;
438
FCFLAGS="${FCFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}" ; export FCFLAGS ;
439
%{?__global_ldflags:LDFLAGS="${LDFLAGS:-%__global_ldflags}" ; export LDFLAGS ;}
440
cmake \
441
    -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
442
    -DCMAKE_CXX_FLAGS_RELEASE:STRING="-DNDEBUG" \
443
    -DCMAKE_Fortran_FLAGS_RELEASE:STRING="-DNDEBUG" \
444
    -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \
445
    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
446
    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
447
    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
448
    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
449
    -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
450
%if "%{?_lib}" == "lib64"
451
    %{?_cmake_lib_suffix64} \
452
%endif
453
    -DBUILD_SHARED_LIBS:BOOL=ON \
454
%else # if 0${?suse_version}
455
%cmake \
456
%endif
457
    -DBoost_NO_BOOST_CMAKE=TRUE \
458
    -Wno-fatal-errors -Wno-errors \
459
    -DCMAKE_SKIP_RPATH=ON \
460
    -DCMAKE_PREFIX_PATH=%{_libdir} \
461
%if 0%{?rhel} >= 8 || 0%{?fedora}
462
    -DQT5_BUILD=ON \
463
%endif
464
    -DINCLUDE_INSTALL_DIR=%{_includedir} \
465
%if 0%{?with_csharp} > 0
466
    -DCSHARP_BINDINGS=ON \
467
    -DCSHARP_INSTALL_DIR=%{_datadir}/%{name}/csharp/ \
468
%endif
469
%if 0%{?with_java} > 0
470
    -DJAVA_BINDINGS=ON \
471
    -DJAVA_INSTALL_DIR=%{_datadir}/%{name}/java/ \
472
%endif
473
%if 0%{?with_php} > 0
474
    -DPHP_BINDINGS=ON \
475
    -DPHP_INSTALL_DIR=%{php_extdir} \
476
%endif
477
%if 0%{?with_python} > 0
478
    -DPYTHON_BINDINGS=ON \
479
    -DPYTHON_INCLUDE_DIRS=%{python2_include} \
480
    -DPYTHON_INSTALL_DIR=%{python2_sitearch} \
481
%endif
482
    ..
483
make
484
popd
485
popd
486
487
%if 0%{?with_python3} > 0
488
    pushd %{name}-%{version}-python3
489
    rm -rf build
490
    mkdir -p build
491
    pushd build
492
    %cmake \
493
        -DBoost_NO_BOOST_CMAKE=TRUE \
494
        -Wno-fatal-errors -Wno-errors \
495
        -DCMAKE_SKIP_RPATH=ON \
496
        -DCMAKE_PREFIX_PATH=%{_libdir} \
497
%if 0%{?rhel} >= 8 || 0%{?fedora}
498
        -DQT5_BUILD=ON \
499
%endif
500
        -DINCLUDE_INSTALL_DIR=%{_includedir} \
501
        -DPYTHON_BINDINGS=ON \
502
        -DPYTHON_INCLUDE_DIRS=%{python3_include} \
503
        -DPYTHON_INSTALL_DIR=%{python3_sitearch} \
504
        ..
505
    make
506
    popd
507
    popd
508
%endif
509
510
511
%if 0%{?plesk}
512
%if 0%{?rhel} < 9
513
for version in 7.2 7.3 7.4 8.0 8.1; do
514
%else
515
for version in 7.4 8.0 8.1; do
516
%endif
517
    pushd %{name}-%{version}-${version}
518
    rm -rf build
519
    mkdir -p build
520
    pushd build
521
    %cmake \
522
        -DBoost_NO_BOOST_CMAKE=TRUE \
523
        -Wno-fatal-errors -Wno-errors \
524
        -DCMAKE_SKIP_RPATH=ON \
525
        -DCMAKE_PREFIX_PATH=%{_libdir} \
526
%if 0%{?rhel} >= 8 || 0%{?fedora}
527
        -DQT5_BUILD=ON \
528
%endif
529
        -DINCLUDE_INSTALL_DIR=%{_includedir} \
530
%if 0%{?with_php} > 0
531
        -DPHP_BINDINGS=ON \
532
        -DPHP_INCLUDE_DIR=/opt/plesk/php/${version}/include/php/ \
533
        -DPHP_EXECUTABLE=/opt/plesk/php/${version}/bin/php \
534
        -DPHP_INSTALL_DIR=/opt/plesk/php/${version}/lib64/php/modules/ \
535
%endif
536
        ..
537
    make
538
    popd
539
    popd
540
done
541
%endif
542
543
%install
544
rm -rf %{buildroot}
545
pushd %{name}-%{version}
546
pushd build
547
make install DESTDIR=%{buildroot} INSTALL='install -p'
548
popd
549
550
%if 0%{?with_php} > 0
551
mkdir -p \
552
    %{buildroot}/%{_datadir}/%{php} \
553
    %{buildroot}/%{php_inidir}/
554
cat > %{buildroot}/%{php_inidir}/kolabformat.ini << EOF
555
extension=kolabformat.so
556
EOF
557
%endif
558
popd
559
560
%if 0%{?with_python3} > 0
561
    pushd %{name}-%{version}-python3
562
    pushd build
563
    make install DESTDIR=%{buildroot} INSTALL='install -p'
564
    popd
565
    popd
566
%endif
567
568
%if 0%{?plesk}
569
%if 0%{?rhel} < 9
570
for version in 7.2 7.3 7.4 8.0 8.1; do
571
%else
572
for version in 7.4 8.0 8.1; do
573
%endif
574
    pushd %{name}-%{version}-${version}
575
    pushd build
576
    make install DESTDIR=%{buildroot} INSTALL='install -p'
577
    popd
578
579
    mkdir -p \
580
        %{buildroot}/opt/plesk/php/${version}/share/php/ \
581
        %{buildroot}/opt/plesk/php/${version}/etc/php.d/ \
582
        %{buildroot}/opt/plesk/php/${version}/etc/php-fpm.d/
583
584
    echo "extension=kolabformat.so" > %{buildroot}/opt/plesk/php/${version}/etc/php.d/kolabformat.ini
585
    cp %{buildroot}/opt/plesk/php/${version}/etc/php.d/kolabformat.ini \
586
        %{buildroot}/opt/plesk/php/${version}/etc/php-fpm.d/
587
    popd
588
done
589
%endif
590
591
%check
592
pushd %{name}-%{version}/build
593
# Make sure libkolabxml.so.* is found, otherwise the tests fail
594
export LD_LIBRARY_PATH=$( pwd )/src/
595
pushd tests
596
./bindingstest
597
./conversiontest
598
./parsingtest
599
popd
600
%if 0%{?with_php} > 0
601
php -d enable_dl=On -dextension=src/php/kolabformat.so src/php/test.php ||:
602
%endif
603
%if 0%{?with_python} > 0
604
python src/python/test.py ||:
605
%endif
606
popd
607
608
%if 0%{?with_python3} > 0
609
    pushd %{name}-%{version}-python3/build/
610
    export LD_LIBRARY_PATH=$( pwd )/src/
611
    python3 src/python/test.py ||:
612
    popd
613
%endif
614
615
%if 0%{?plesk}
616
%if 0%{?rhel} < 9
617
for version in 7.2 7.3 7.4 8.0 8.1; do
618
%else
619
for version in 7.4 8.0 8.1; do
620
%endif
621
622
    pushd %{name}-%{version}-${version}/build/
623
    export LD_LIBRARY_PATH=$( pwd )/src/
624
    /opt/plesk/php/${version}/bin/php -d enable_dl=On -dextension=src/php/kolabformat.so src/php/test.php ||:
625
    popd
626
done
627
%endif
628
629
%clean
630
rm -rf %{buildroot}
631
632
%post -p /sbin/ldconfig
633
634
%postun -p /sbin/ldconfig
635
636
%files
637
%defattr(-,root,root,-)
638
%doc %{name}-%{version}/DEVELOPMENT %{name}-%{version}/NEWS %{name}-%{version}/README
639
%{_libdir}/*.so.*
640
641
%if 0%{?suse_version}
642
%files -n libkolabxml-devel
643
%else
644
%files devel
645
%endif
646
%defattr(-,root,root,-)
647
%{_includedir}/kolabxml
648
%{_libdir}/*.so
649
%{_libdir}/cmake/Libkolabxml
650
651
%if 0%{?with_csharp} > 0
652
%files -n csharp-kolabformat
653
%defattr(-,root,root,-)
654
%dir %{_datadir}/%{name}
655
%{_datadir}/%{name}/csharp
656
%endif
657
658
%if 0%{?with_java} > 0
659
%files -n java-kolabformat
660
%defattr(-,root,root,-)
661
%dir %{_datadir}/%{name}
662
%{_datadir}/%{name}/java
663
%endif
664
665
%if 0%{?with_php} > 0
666
%files -n php-kolabformat
667
%defattr(-,root,root,-)
668
%{php_extdir}/kolabformat.so
669
%config(noreplace) %{php_inidir}/kolabformat.ini
670
671
%if 0%{?plesk}
672
%if 0%{?rhel} < 9
673
%files -n plesk-php72-kolabformat
674
%defattr(-,root,root,-)
675
/opt/plesk/php/7.2/lib64/php/modules/kolabformat.so
676
/opt/plesk/php/7.2/etc/php.d/kolabformat.ini
677
/opt/plesk/php/7.2/etc/php-fpm.d/kolabformat.ini
678
679
%files -n plesk-php73-kolabformat
680
%defattr(-,root,root,-)
681
/opt/plesk/php/7.3/lib64/php/modules/kolabformat.so
682
/opt/plesk/php/7.3/etc/php.d/kolabformat.ini
683
/opt/plesk/php/7.3/etc/php-fpm.d/kolabformat.ini
684
685
%endif
686
%files -n plesk-php74-kolabformat
687
%defattr(-,root,root,-)
688
/opt/plesk/php/7.4/lib64/php/modules/kolabformat.so
689
/opt/plesk/php/7.4/etc/php.d/kolabformat.ini
690
/opt/plesk/php/7.4/etc/php-fpm.d/kolabformat.ini
691
692
%files -n plesk-php80-kolabformat
693
%defattr(-,root,root,-)
694
/opt/plesk/php/8.0/lib64/php/modules/kolabformat.so
695
/opt/plesk/php/8.0/etc/php.d/kolabformat.ini
696
/opt/plesk/php/8.0/etc/php-fpm.d/kolabformat.ini
697
698
%files -n plesk-php81-kolabformat
699
%defattr(-,root,root,-)
700
/opt/plesk/php/8.1/lib64/php/modules/kolabformat.so
701
/opt/plesk/php/8.1/etc/php.d/kolabformat.ini
702
/opt/plesk/php/8.1/etc/php-fpm.d/kolabformat.ini
703
704
%endif # if 0%{?plesk}
705
706
%endif # if 0%{?with_php}
707
708
%if 0%{?with_python} > 0
709
%files -n python-kolabformat
710
%defattr(-,root,root,-)
711
%{python2_sitearch}/kolabformat.py*
712
%{python2_sitearch}/_kolabformat.so
713
%endif
714
715
%if 0%{?with_python3} > 0
716
%files -n python3-kolabformat
717
%defattr(-,root,root,-)
718
%{python3_sitearch}/kolabformat.py*
719
%{python3_sitearch}/_kolabformat.so
720
%if 0%{?rhel} >= 8
721
%pycached %{python3_sitearch}/kolabformat.py
722
%else
723
/usr/lib64/python3.6/site-packages/__pycache__/kolabformat.cpython-36.opt-1.pyc
724
/usr/lib64/python3.6/site-packages/__pycache__/kolabformat.cpython-36.pyc
725
%endif
726
%endif
727
728
%changelog
729
* Tue Feb 15 2022 Christian Mollekopf <mollekopf@kolabsys.com> - 1.2.1
730
- Release of version 1.2.1
731
732
* Tue May 14 2019 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 1.2.0
733
- Release of version 1.2.0
734
735
* Thu May 28 2015 Christian Mollekopf <mollekopf@kolabsys.com> - 1.2
736
- New upstream release
737
- Removed dependency on kdepimlibs and kdelibs which is not required
738
739
* Mon Jan 13 2014 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 1.0.1-2
740
- Require php-kolab for php-kolabformat, and void
741
  /etc/php.d/kolabformat.ini (#2667)
742
743
* Wed Oct 30 2013 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 1.0.1-1
744
- New upstream release
745
746
* Mon Oct 14 2013 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 1.0.0-1
747
- New upstream release
748
749
* Sun May 19 2013 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 1.0-0.1
750
- Snapshot as required by the latest versions of roundcubemail-plugins-kolab
751
  and iRony
752
753
* Thu Apr 11 2013 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.8.4-1
754
- New upstream release
755
756
* Tue Feb 26 2013 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.8.3-1
757
- New upstream release with file format handling
758
759
* Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 0.8.1-4
760
- Rebuild for Boost-1.53.0
761
762
* Sat Feb 09 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 0.8.1-3
763
- Rebuild for Boost-1.53.0
764
765
* Wed Aug 22 2012 Dan Horák <dan[at]danny.cz> - 0.8.1-2
766
- build csharp subpackage only when Mono exists
767
768
* Wed Aug 15 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.8.1-1
769
- New upstream version 0.8.1
770
- Revert s/qt-devel/qt4-devel/ - just require the latest qt-devel
771
- Revert s/kdelibs-devel/kdelibs4-devel/ - also require the latest
772
  kdelibs (frameworks FTW!)
773
774
* Sun Aug 12 2012 Rex Dieter <rdieter@fedoraproject.org> - 0.7.0-3
775
- drop BR: gcc-c++
776
- s/qt-devel/qt4-devel/ s/kdelibs-devel/kdelibs4-devel/
777
- fix build against boost-1.50
778
779
* Wed Jul 25 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.0-2
780
- Fix build on ppc64
781
- New upstream version
782
783
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-4
784
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
785
786
* Wed Jun 27 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.6.0-3
787
- Correct dependency on php
788
789
* Tue Jun 26 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.6.0-2
790
- Also remove xsd-utils requirement for -devel sub-package
791
792
* Mon Jun 25 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.6.0-1
793
- Actual 0.6.0 release
794
795
* Sat Jun 23 2012 Christoph Wickert <wickert@kolabsys.com> - 0.6-1
796
- Update to 0.6 final
797
- Run ldconfig in %%post and %%postun
798
- Mark kolabformat.ini as config file
799
- Export LD_LIBRARY_PATH so tests can be run in %%check
800
- Add php dependencies to php-kolabformat package
801
- Make base package requirements are arch-specific
802
- Filter unwanted provides of php-kolabformat and python-kolabformat
803
804
* Wed Jun 20 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.6-0.4
805
- Some other cleanups to prevent review scrutiny from blocking
806
  inclusion
807
- Drop build requirement for xsd-utils
808
809
* Sat Jun  9 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.6-0.2
810
- Git snapshot release
811
812
* Wed May 23 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.5-5
813
- Correct use of Python keyword None
814
- Snapshot version with attendee cutype support
815
816
* Tue May 22 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.5-3
817
- Snapshot version with attendee delegation support
818
819
* Sat May 12 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.5-2
820
- Snapshot version with build system changes
821
822
* Wed May  9 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.4.0-3
823
- Fix PHP kolabformat module packaging
824
825
* Wed May  2 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.4.0-2
826
- New version
827
828
* Fri Apr 20 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.3.0-1
829
- New version
830
831
* Mon Apr  9 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.3-0.1
832
- First package
833
834